让SmartCrop支持ImageMagick库

标签:

默认的SmartCrop模块只支持GD2,但是ImageMagick处理图片更快,缩略图更小,所以生产服务器我们开启了ImageMagick库,这样导致了不兼容SmartCrop模块,后来找到如下patch可以参考,开发了一个SmartCrop的补丁。

https://drupal.org/node/929880