Site pages access


This project is not covered by Drupal’s security advisory policy.

Site pages access configuration page

-- SUMMARY --

This module provides control on site page access

-- REQUIREMENTS --

Nested checkbox
jQuery Update (jQuery v1.6 or later)
Libraries API

-- INSTALLATION --

To make this module work, you should download jQuery tristate checkbox plugin
(https://jlbruno.github.io/jQuery-Tristate-Checkbox-plugin/) and extract it in
the "libraries" folder of your site (renaming if necessary) so that the path
is libraries/tristate/jquery.tristate.min.js
In jQuery Update settings, select jQuery v1.7 or 1.8
Then install module as usual.

-- CONFIGURATION --

Set permissions to allow some roles to configure access to some menus' items

-- CUSTOMIZATION --

Policy of accessibility to blocked pages (administrator is allways availible):
hook_site_pages_access_deny_validate_alter(&$bypass)

Actions to do on attempt to access to not allowed pages:
hook_site_pages_access_deny_callback_alter(&$router_item, $path, $original_map, $original_router_item_access_callback)


Site pages access项目的Drush安装命令:复制到剪贴板

注:个别模块仍需开启相关子模块。

推荐版本下载:

版本下载地址发布日期发布说明翻译下载
7.x-1.0-beta2tar.gz (9.65 KB) | zip (11.41 KB)2018年4月13日发布说明简 | 繁 | 更多